@cho_co


※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

@cho_co

概要

勉強会で必要と思われるソフトウェアは以下。
ちなみにMac OS X Leopard環境です。

  • Ruby
  • Rails(フレームワーク)
  • RubyGems(Rubyのパッケージ管理システム)
  • SQLiteかMySQL(Leopardには標準でSQLiteが入ってる)
  • Aptana(統合開発環境)
  • RadRails(Rails開発環境、Aptanaのプラグインとして提供される)

他に必要な物があれば教えてください。
Mac OS X Leopardには標準で環境が入っているのでこれらをアップデートする。

各種ソフトウェアのアップデート

RubyGem

  • RubyGemのバージョン確認
chocosMacBook:~ choco$ gem -v
1.0.1
  • RubyGemのアップデート
chocosMacBook:~ choco$ sudo gem update --system
Password:
Updating RubyGems...
Bulk updating Gem source index for: http://gems.rubyforge.org
Attempting remote update of rubygems-update
Successfully installed rubygems-update-1.3.1
(中略)
RubyGems system software updated
RubyGemのバージョン確認
chocosMacBook:~ choco$ gem -v
1.3.1

バージョン1.0.1から1.3.1になった。

Rails

  • Railsのバージョン確認
chocosMacBook:~ choco$ rails -v
Rails 1.2.6
  • Railsのアップデート
chocosMacBook:~ choco$ sudo gem install rails
Password:
Successfully installed rake-0.8.4
(中略)
Installing RDoc documentation for activeresource-2.3.2...
  • Railsのバージョン確認
chocosMacBook:~ choco$ rails -v
Rails 2.3.2

バージョン1.2.6から2.3.2になった
大幅なバージョンアップ。

Ruby

  • Rubyのバージョン確認
chocosMacBook:~ choco$ ruby -v
ruby 1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]
  • Rubyのアップデート
chocosMacBook:~ choco$ sudo port install ruby

PortコマンドとはMacPortsのこと(パッケージ管理システム)

...でインストールできるはずなんだけど依存関係のエラーが出てダメだった。
Rubyはとりあえず置いておこう。バージョンは1.8.6のまま。

Aptana

http://www.aptana.com/
からAptanaをダウンロード・インストール。

日本語化はめんどくさいからまだしてない。

RadRails

AptanaのPluginsからインストール。
Eclipseを使った事があるのであれば簡単かと。
手順はあとで書くと思う。

何かあればコメントお願いします。
名前:
コメント: